
Compiled by

Veerapandian.K

Mechanical Engg

Vedharanyam-614 810

A manual to mechanical designers

How Solid works Works?
Solid works Overview
Solid works main idea is user to create drawing directly in 3D or solid form. From this 
solid user can assemble it directly on their workstation checking clashes and functionality 
of it. Creating drawing is pretty easy just drag and drop the solid to drawing block. 

Part

Part is created by sketch. 
Sketch is the base to define your part, form and features. 



Before you start creating sketches you must select plane or face where the sketch will be 

place on. 

After select plane or face the sketch will be, sketch on it! 



When you done with sketch, adding features it is your next step. Select Feature>Extruded 

Cut 
Select through All and OK. 



Learn how to create this part step by step solid works tutorial here

Assembly
Assembly is how all parts works together in assembly, checking for clashes and it 
functionality. First all parts inserted in assembly by Insert Component tool. 

When all parts inserted into workspace, Mate is command to define how parts mate with 

each other. 
Let’s mate this block and pin together, click Mate and select pin face and hole face, OK.

http://www.solidworkstutorials.com/2009/01/solidworks-tutorial/


Drawing
Drawing is use for detailing part by adding dimension to it. To create a drawing first you 
need to select drawing block. 



When block inserted, select click view palette to add drawing view. 

Choose the part you wish to make drawing. 
Now just drag and drop the part view on drawing block and add dimensions. 



Summary
Solid works works by it user creating part in 3D or solid form. Three solid works 
component is Part, Assembly and Drawing. Part define by it sketch and selected feature. 
Assembly is how all parts assemble in one unit; parts assemble by user adding mate 
between parts. Drawing is for detailing and adding dimensions to part.



1. How to create simple cube

1. Click New , Click Part and OK.

2. Click on Top Plane and click Sketch.

3. Click Rectangle , sketch a rectangle start from origin.

4. Click Smart Dimension , click side edge and click top edge to dimension it as 
1.0in x 1.0in.

5. Click Features>Extruded Boss/Base

Set D1 as 1.0in



And click .

6. it’s done. Simple Right?

2. How to use revolved cut



In this tutorial, you will create this part using revolved feature tools.

1.Click New. Click Part,  OK.

2.Click Front Plane and click on Sketch.

3.Click Rectangle, sketch rectangular. Click Smart Dimension, 
dimension rectangular 3in x 3in.



4.Click Feature>Extruded Boss/Base, set D1 to 2in 

and .

5.Click on front face and click Sketch.

6. Click Circle, and sketch a circle on front face.



7. Click Smart Dimension, dimension sketch as below sketched.

8.Click Features>Revolved Cut click on right side edge as axis of 
revolution,

and .



9. You’re done!

3. Create spring

1. Click New  (File>New) , click Part , OK .

2. Click Option  (Tools>Option…) , select Document Properties tab. Select Units , 
under Unit System select IPS (inch, pound, second) OK.



3. Select Top Plane , from lower left menu select Normal To. 

4. Click Sketch  in Command Manager, click Circle . As you 
can see on upper right corner sketch icon appear indicate that you’re on sketch mode

.



5. Pick Origin  point as starting point, drag to right hand side

 no need to be exact the size will define in later step. Press 
keyboard ESC to end circle sketch.

Note: There is two type line generated by in sketching, the one with black line and blue 
line. Black line is line that fully defined and blue line is under defined..

6. Define sketch with dimension. Click Smart Dimension  , and start 

dimensioning pick circle edge and set to 0.50in . Press keyboard 
ESC to end smart dimension.

7. Change display to Isometric view. 



8. Insert coil, Click Insert>Curve>Helix/Spiral 

.

9. Press F to zoom fit, set Parameters Constant Pitch , Pitch 0.10in Revolutions 4 , Start 

angle 0.0deg and . 



10. Click to Right Plane  , click Normal To 

.

11. Click Sketch , click Circle . Sketch circle at start point, then click Smart dimension 

set circle diameter to 0.05in . 

12. Click exit sketch . Click Features  and activate features 

menu. Click Swept Boss/Base  and set Profile to Sketch2 by click on circle 



sketch  and set Path by click 

helix path  and .

13. Change display to Isometric view. 

14. Press F to zoom fit.

Done. Pat yourself on back.



4. Create 1/2″ Hex Bolt

1. Sketch a polygon with 6 side, Tools>Sketch Entities>Polygon 

set diameter to 0.75in.

2. Extrude  sketch to 0.34in.
3. Create minor diameter for thread, sketch circle on top face, set diameter to 0.4in.



4. Extrude sketch to 1.1in.

5. Click end edge of thread shaft,  click convert entities .



6. Select Helix/Spiral feature set height to 1.2in, theap per inch=pitch 13/1in  

Ok.

7. Right click on Front plane, Insert sketch  sketch thead profile. 



8. Click sweep feature ,  select sketch profuile as 

sketch and helix as a path, OK.

9. Create skecth a circle on the end shaft,  extrude cut 0.1in 

.



10. Finish.



5. How to create gear

In this solidworks tutorial, you will create gear.

1. Click New. Click Part, OK.
2. Click Front Plane and click on Sketch.

3. Click Circle and sketch a circle center at origin. Click Smart Dimension, 

click sketched circle and set it diameter to 1in.



4. You just completed your sketch, let’s build feature from it. Click Features>Extruded 

Boss/Base. 

Set D1 to 0.1in and . 

5. Click on front face and click Normal To.

6. Click on front face and click Sketch.

7. Click on Centerline and sketch vertical Centerline.



8. Click Line and sketch gear teeth profile.

9. Click Smart Dimension, dimension sketch as sketched below.



10. Change view to Isometric.

11. Click Feature>Extruded Boss/Base. 

Set D1 to 0.1in, click Reverse Direction and .

12. Click on Extrude2 (gear teeth) and click Circular Pattern. 

Click on the cylinder face as axis of rotation (or click on View>Temporary Axes select 
the temporary axis as axis of rotation).



Set Instances to 22 and .

13. Click on Front face and select Normal To.

14. Click on front face and select Sketch.



15. Sketch a Circle and sketch a circle center at origin. Click Smart Dimension, 

dimension sketch as 0.9in circle.

16. Click Features>Extruded Cut and set D1 to 0.01in and .

17. Click on inner front face and select Sketch.



18. Click Circle and sketch a circle center at origin. Click Smart Dimension, 

dimension circle as 0.3in circle.

19. Click Features>Extruded Boss/Base set D1 to 0.1in and .

20. Click on center face and select Sketch.



21. Click Circle and sketch a circle center at origin. Click Smart Dimension, 

dimension circle as 0.15in circle.

22. Click Features>Extruded Cut and set Direction to Through All and .
23. Repeat Step 13 – 22 to back side face and you’re done!



6. Curve Driven Pattern

1. Create new part, sketch egg shape on top plane using spline . 

2. Extrude shape to 0.3in , click top 

face and right click Insert Sketch. 



3. Select part edge and click offset 

to 0.3in . Exit Sketch .



4. Click hole wizard , select Countersink, Ansi Inch, Flat Head Screw, #10, Normal, 

Through All . Click Positions , click screw point at curve edge. 

OK. 

5. Select CSK for #10 Flat Head Machine Screw , Click 
Insert>Pattern/Mirror>Curve Driven Pattern… 

Define Pattern, select spline sketch and set 



# to 10, Equal spacing 

. OK, done. 

7. How to create helical gear



In this solidworks tutorial, you will create helical gear.

1. Click New. Click Part, OK.
2. Click Front Plane and click on Sketch.



3.    Click Circle and sketch a circle center at origin. Click Smart Dimension, 

click sketched circle and set it diameter to 1.0in.

4.    You just completed your sketch, let’s build feature from it. Click 

Features>Extruded Boss/Base. 

Set D1 to 0.3in and .

5.    Click on front face and click Normal To.

6.    Click on front face and click Sketch.



7.    Click on Centerline and sketch vertical Centerline.

8.    Click Line and sketch gear teeth profile.

9.    Click Smart Dimension, dimension sketch as sketched below.



10.    Click Exit Sketch, change view to Isometric.



11. Click scroll mouse button and rotate the part to back side.

Click the back face and select Normal To. Click on this face again and click Sketch.

12. We will trace last sketch to this face, while holding CTRL click all sketched line

and click Convert Entities . Now we need removed all 
relation between this sketch and the other sketch, click Display/Delete Relations 

click Delete All



and .

13. Click and drag select all the sketch line.

Click on Rotate Entities,

Click Center of Rotation box

and click origin (center part).



On Parameter option enter 10 deg rotation.

and .



14. Click Exit Sketch, change view to Isometric.

15. Click Features>Lofted Boos/Base,

open up part tree and double click Sketch2 and Sketch3 to add for lofted features.



Make sure two green point is at the same edge as other sketch, if not drag and relocate it.

and .

12.    Click on Loft1 (gear teeth) and click Circular Pattern. 

Click on the cylinder face as axis of rotation (or click on View>Temporary Axes select 



the temporary axis as axis of rotation).

Set Instances to 22 and  .



13.    Click on Front face and select Normal To.

14.    Click on front face and select Sketch.

15.    Sketch a Circle and sketch a circle center at origin. Click Smart Dimension, 

dimension sketch as 0.40in circle.



16.    Click Features>Extruded Cut and set Direction to Through All and .

17.    Click on front face and select Sketch.

18.    Click Rectangle and sketch a rectangle as sketched. Click Smart Dimension, 

dimension rectangle as skecthed below.

16.    Click Features>Extruded Cut and set Direction to Through All and . 
You’re done!



8. How to twist phone cord
Learn how to create twist phone cord… with you mouse





First you need to have spiral, with circle base 2″ , 2 revolution and 2 pitch. Don’t know 
how? Refer this tutorial; Tutorial #2: How to create simple spring

Now add a plane at end of spiral, select parallel to front plane.

http://www.solidworkstutorials.com/2009/2009/05/tutorial-2-how-to-create-simple-spring/


Sketch a circle on Plane2, 0.08″ and 0.15 height. Click Swept Boss/Base. 

Select Sketch3 as profile and Helix/Spiral1 as path.

Open up Options and set Twist Along Path, define by Turns and 50 turns.



And OK you’re done!

9. How to check part mass



You can check part mass by assigning part material first, example for this bracket

I set it material as plain carbon steel

Now material set as Plain Carbon Steel

Click Evaluate>Mass properties



and you got the mass is 0.09 pounds. You also can check it volume, surface area and 
center of mass.

10. How to create bottle cap



I get this idea from my medicine bottle cap, the tips here show you how you can use 
extrude up to the face function.

1. Click New , Click Part and OK.

2. Click on Top Plane and click Sketch.

3. Click Circle and sketch start at Origin, click Smart Dimension and 
dimension the circle as 1.0in diameter.



4. Click Features>Extrude Boss/Base set the D1 to 0.5in

and .

5. Click Fillet , set fillet size as 0.1in, select top face of the part

and .

6. Turn the part to view bottom side, set D1 as 0.05in, click Shell , select 
bottom face



and .

7. Click Isometric View , click on Front Plane

and click on Reference Geometry>Plane.

Set distance to 0.65in

and .



8. Click Plane1 and click Sketch.

9. Click Rectangle , sketch on Plane1 as sketched below and use Smart Dimension 
for your dimensioning.

10. Click Features>Extrude Boss/Base set the Up To Surface

and .



11. Click Fillet , set fillet size as 0.1in, select side edge of the lid.

and .

12. And you’re done!

11. Stress strength test in Solid Works
In this tutorial, you will analyze this part using SimulationXpress in solidworks



1. Click New. Click Part, OK.
2. Click Front Plane and click on Sketch.

3. Click Rectangle, sketch a rectangular.

Click Smart Dimension, dimension rectangular 0.25in x 0.25in.

4. Click Feature>Extruded Boss/Base, set D1 to 3.0in



and .
5. For analysis, click Evaluate>SimulationXpress Analysia Wizard

Click Options…

6. Set system unit to English (IPS), Next.

7. Set materials type, select Steel, 1023 Carbon Steel, Apply. Next.



Next

Next



8. Turn the model to view it back side, select back face, Next.

Next.



Next.

9. Select load type, Click Pressure. Next.



10. Select model top face as location of pressure acting. Next.

11. Set pressure value to 1000psi, Next.



Next,

Next,



12. To run the analysis, click Run.

Next,



Select No, Next,

Click Next to view stress distribution in the model,



To animate the analysis click Play button, click Next when you done.



13. To view the displacement distribution, click Show me the displacement distribution 
in the model and Next,

To animate analysis click Play button. Done!



12. How to create U bracket sheet metal



In this tutorials you will learn how to 
create U bracket sheetmetal.

1. Click New. Click Part, OK.
2. Click Front Plane and click on Sketch.

Use Line , sketch U shape. Dimension sketch with Smart Dimension as 1in 
x 1.5in x1in and 1.5in height.

3. Click Offset Entities and click U sketch. Set offset distance as 0.1in, check 
Reverse box and OK.



4. Use Line , sketch and connected open end of this sketch and make it close both 
end.

5. Click Features>Extruded Boss/Base set D1 to 1in and OK.



6. Click View>Bottom

click on bottom face and click Sketch.

7. Click Circle and sketch 2 circle on bottom face each side. Use Smart Dimension 

to dimension this sketch as sketched below.



8. Click Features>Extruded Cut and cut Through All this circle.

9. Click View>Isometric.

10. Click Fillet , check box Full round fillet.



11. Click side left side face as Side Face 1.

12. Click on purple box and click center face as Center Face Set.



13. Click on pink box and click right side face as Side Face Set2 and OK.

14. Repeat step 11 - 13 for the other side.



15. Repeat step 11 - 13 for inner face and outer face of U bracket.



16. Click Sheetmetal>Insert Bends, click flat face as reference when it flatten. Set 
bend radius to 0.03in and K factor 0.5 and OK.

17. Your simple sheetmetal bend is ready. Look at part tree.



18. To view this part in flatten form click Sheetmetal>Flatten .

Have fun.. If you cannot find the sheetmetal tool in you main tool menu, you can right 
click on main menu tab and check Sheetmetal option.

13. Create simple sheet metal bend



In this tutorials you will learn how to utilize 
sheetmetal tool such insert bend and flaten.

1. Click New. Click Part, OK.
2. Click Front Plane and click on Sketch.

Use Line , sketch L shape. Dimension sketch with Smart Dimension as 1in 
x 1in.

3. Click Offset Entities and click L sketch. Set offset distance as 0.1in.



4. Use Line , sketch and connected open end of this sketch and make it close both 
end.

5. Click Features>Extruded Boss/Base set D1 to 0.5in and OK.



6. Click Sheetmetal>Insert Bends, click flat face as reference when it flatten. Set 
bend radius to 0.03in and K factor 0.5 and OK.

7. Your simple sheetmetal bend is ready. Look at part tree.

8. To view this part in flatten form click Sheetmetal>Flatten.



Have fun.. If you cannot find the sheetmetal tool in you main tool menu, you can right 
click on main menu tab and check Sheetmetal option.

You know the basic, try model this bracket.

No idea? Wait for this SolidWorks tutorial on my next post..

14. How to model aero plane wings



Last week my friends ask me how to model RC (remote control) wings in solidworks? He 
tried to model by extruding the sketch but it didn’t reflect what the real wings. So he 
email me this picture of RC wings for me to look at. After reviewing the wings shape, I 
told him he can model these wings by loft features. Let’s model these wings together.

1. Click New, Part and OK.

2. Click on Right Plane and click Sketch.

3. Sketch a center aerofoil profile at this plane. Click Line, sketch a horizontal line, 

click Smart Dimension and dimension the line as 6in.

4. To create top curve of aerofoil, click Spline, and sketch top curve as sketched 
below, to end Spline press Esc key.



Exit the sketch. 

5. For another aerofoil profile at wing tip, you need to create another plane. Click on 

Right Plane and click Reference Geometry>Plane 

set distance between plane as 10in and .

6. Click on Plane 1 and click Sketch.

7. Click Line, sketch a horizontal line on same level as first sketch a bit off set from 

origin, click Smart Dimension and dimension sketch as sketched below.

8. To create top curve of aerofoil, click Spline, and sketch top curve as sketched 
below, to end Spline press Esc key.

Exit the sketch.



9. Click View Oreintation>Isometric.

10. Click Features>Lofted Boss/Base,

click Sketch1 and then Sketch2.

and .

11. To hide Plane 1, click Plane 1 and click Hide.



12. Now let make the full wings, click on Mirror. Turn the wings to right side 
and select center face as a Mirror Face/Plane.

Click on wing body as Features to Mirror

and .

13. You’re done.



15. How to create Allen key

In this solidworks tutorial, you will create simple allen key.

1. Click New. Click Part, OK.

2. Click Front Plane and click on Sketch.



3. Click Line, skecth a L shape.

4. Click Smart Dimension, and dimension sketch as 2.5″ and 1″.

5. Click Sketch Fillet, add 0.3″ fillet at L corner.



6. Exit sketch, click on Top Plane and click Sketch.

7. Click on Sketch2 and click Normal To.

8. Click Polygon, sketch a polygon at origin.

9. Click Smart Dimension, and dimension sketch diameter to 0.15″.



10. Exit sketch, click on Isometric view.

11. Click Features>Swept Boss/Base, 
for profile click on Sketch2 and for path click on Sketch1 and OK.



You’re done!.

16. How to change to metric units
There is time we need to change our parts to metric units, but how? It’s very simple just 
few clicks its done. First click Option on top of main menu, 

open Document Properties tab, 

select Units in menu tree and check MMGS 

(millimeter, gram, second). 
Ok, done!
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